Friday, July 22, 2011

Ipv6 general -prefix

ipv6 general-prefix command is a great help when its come to configuration of IPv6 address. As we all know that when IPv6 address are 128 bits which is lengthy. When it comes to configuration of interfaces, we need to key in a long strings of hexadecimal digits. The command will make the configuration less tedious.


Take for example, ISP assigned you an IPv6 address 2003:abcd:1234::/48. Most of your interfaces on the router will most probabaly be configured within this prefix.


ipv6 general-prefix ISPIssued 2003:345:ABCD::/48


So if we want to assigned 2003:345:ABCD::1/64 to interface fa0/1


We just simply need to


int fa0/1
ipv6 address ISPIssued ::1/64


That's it. We don't have to worry that we will mistype the wrong prefix for the IPv6 addresses for all our interfaces. Noted that an interface can have more than one IPv6 addresses, so any mistype will need to be manually removed by the negate command.



Wednesday, June 22, 2011

Tuesday, May 10, 2011

DHCP configuration

Given a scenario of auto-assigning the range of address 192.168.30.0/24 to your host and to reserve the first 10 ip of the range to your static devices such as servers, printers, routers' interfaces etc ... ...


ip dhcp excluded-address 192.168.30.1 192.168.30.10  => tell dhcp server no to assign 1st 10 address


ip dhcp pool TEST  => create a TEST pool to start assigning address
network 192.168.30.0 255.255.255.0  
=> range of address to assign, will check with excluded-address to start the ip assignment
default-router 192.168.30.1  => define the default gateway to be used by PC
dns-server 192.168.30.10  => define the dns server to be used for resolving URL to IP address




For Voice configuration support
option 150 ip 192.168.30.1  => assuming CME installed on the router


Why option 150?
Cisco phones require access to a TFTP server that contains device configuration name files (.cnf file format), which enables the device to communicate with Cisco Call Manager. 

Cisco IP Phones download their configuration from a TFTP server. When a Cisco IP Phone starts, if it does not have both the IP address and TFTP server IP address pre configured, it sends a request with option 150 to the DHCP server to obtain this information.



DHCP Option 150 is Cisco proprietary. The IEEE standard that matches with this requirement is Option 66. Like option 150, option 66 is used to specify the Name of the TFTP server.


Option 66 is an open standard juniper supports it. RFC 2132 defines option 66.

Difference between option 150 and option 66


  • DHCP option 150 supports a list of TFTP servers (Multiple Server IPs)
  • DHCP option 66 only supports the IP address or the hostname of a single TFTP server.

Thursday, February 10, 2011

Inter-VLAN routing


Traditional Inter-VLAN
- Separate links are needed for individual VLANs. In the example above, VLAN 10 and VLAN 20 are created. Thus 2 separate fastethernet links are needed to connected to the router.

Configuration on Router2
interface fa0/0
ip address 192.168.10.1 255.255.255.128
no shut
interface fa0/1
ip address 192.168.10.129 255.255.255.128
no shut

Configuration on Switch
=> connection to PC4
interface fa0/10
switchport access vlan 10

=> connection to PC5
interface fa0/20
switchport access vlan 20

=> connection to router2 interface fa0/0
interface fa0/23
switchport access vlan 10

=> connection to router2 interface fa0/1
interface fa0/24
switchport access vlan 20

Router-on-a-stick
- No separate links are needed for individual VLANs. Sub-interfaces are created to connect the Vlans, but ports on switch will need to be set to trunk mode in order for multiple vlans to pass through.

Configuration on Router0
interface fa0/0
no shut
=>good practice to set the sub-interface number to be same as the VLAN id for ease of identification
interface fa0/0.10
encapsulation dot1q 10
ip address 192.168.20.1 255.255.255.128
no shut
interface fa0/1.20
encapsulation dot1q 10
ip address 192.168.20.129 255.255.255.128
no shut

Configuration on Switch
Set the interface connecting to the end device such as client PC to be on the respective VLAN
switchport access vlan 10

Set the interface connecting to another intermediary device such as Router or Switch  to be on Trunk mode to enable multiple VLANs to pass through.
switchport mode trunk

**Make sure all the VLAN are created on all the switch if VLAN Trunking Protocol are not configured

Switch-based Inter-VLAN (L3 switch)
- Layer 3 switch allowed one to use the switch as a Layer 3 device to route traffic between different VLANs

Configuration on Multilayer Switch
ip routing  => to enable L3 function routing on switch
interface VLAN 10   => gateway for VLAN 10
ip address 192.168.30.1 255.255.255.128
no shut
interface VLAN 20   => gateway for VLAN 20
ip address 192.168.30.129 255.255.255.128
no shut
interface fa0/1   => connected to switch for VLAN 10
switchport access vlan 10

interface fa0/2   => connected to switch for VLAN 20
switchport access vlan 20


Configuration on Switch
Set the interface connecting to the device to be on the respective VLAN
switchport access vlan 10